DigitSmith

I need HELP.

Like Tree1Likes
  • 1 Post By dd2

Reply
 
Thread Tools Search this Thread
Old April 24th, 2013, 07:31 PM   #1 (permalink)
argonpicnic argonpicnic is offline
Junior Member
Join Date:
Apr 2013
Posts:
5
Liked:
0 times
Default I need HELP.

All of a sudden my emulsion doesn't work right.

I put it on and it doesn't dry overnight. It takes like two days, and then when it's "dry" it still feels a little sticky and it looks all shiny and streaky. Plus there will be little blobs of emulsion.

I go to spray my pattern out and streaks of emulsion strip away where they're not supposed to.

I've done this many times and it's worked perfectly. Suddenly it's doing this and I don't have the slightest clue why. Please help!!!
Send a private message to argonpicnic ContactReply & Quote
Old April 24th, 2013, 09:59 PM   #2 (permalink)
dgsp7 dgsp7 is online now
Member
Join Date:
Sep 2010
Posts:
44
Liked:
0 times
Default Re: I need HELP.

You need to add some sort of heat source and get the air circulating. I used a wooden box I made with a small heater in it and screens would be thoroughly dry in an hour or so. Letting them dry naturally is difficult depending on temperature, humidity, etc.
Send a private message to dgsp7 ContactReply & Quote
Old April 25th, 2013, 09:05 AM   #3 (permalink)
dd2 dd2 is offline
Junior Member
Join Date:
Apr 2011
Posts:
15
Liked:
1 times
Default Re: I need HELP.

How old is your emulsion?
calking likes this.
Send a private message to dd2 ContactReply & Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


All times are GMT -4. The time now is 03:55 PM.
Copyright © 2011 DigitSmith. All rights reserved.
Forums software by VBulletin, Copyright © 2000-2021, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.